Issue #103

{diagram wizard] Error in consolelog when creating a diagram with diagram wizard

Added by Irina Neculita over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:20 June 2013
Priority:ImmediatDue date:
Assignee:Antonin Abhervé% Done:

100%

Category:Diagrams
Target version:3.0.03

Description

{diagram wizard] Error in consolelog when creating a diagram with diagram wizard

Steps to reproduce:

  1. Create a project and deploy XSD
  2. Select the root -open diagram creation wizard – XSD – Schema

==> diagram created, but error appear in consolelog

!ENTRY org.eclipse.equinox.event 4 0 2013-06-20 15:39:28.154 !MESSAGE Exception while dispatching event org.osgi.service.event.Event [topic=org/modelio/app/edit] to handler org.eclipse.e4.core.di.internal.extens ions.EventObjectSupplier$DIEventHandler@217e35 !STACK 0 org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException

    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:63)
    at org.eclipse.e4.core.di.internal.extensions.EventObjectSupplier$DIEventHandler.handleEvent(EventObjectSupplier.java:83)
    at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:197)
    at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:197)
    at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

Caused by: java.lang.NullPointerException

    at org.modelio.vcore.session.impl.CoreSession.getSession(CoreSession.java:142)
    at org.modelio.gproject.gproject.GProject.getProject(GProject.java:158)
    at org.modelio.editors.richnote.management.RichNoteEditorsManager.onElementEdition(RichNoteEditorsManager.java:77)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:56)
    ... 6 more

History

#1 Updated by Irina Neculita over 4 years ago

  • Priority changed from Medium to High

#2 Updated by Irina Neculita over 4 years ago

  • Priority changed from High to Urgent

error window pop-up with message org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException) Failed to execute runnable (java.lang.NullPointerException)

#3 Updated by Irina Neculita over 4 years ago

Issue also available for Togaf – SOA architect – diagram creation wizard – message diagram; Tracability diagram

#4 Updated by Irina Neculita over 4 years ago

issue available for SQL – persistent class diagram – wizard creation

#5 Updated by Irina Neculita over 4 years ago

  • Priority changed from Urgent to Immediat

#6 Updated by Christophe Malgouyres over 4 years ago

  • Status changed from New to Resolved
  • Target version set to 3.0.03

#7 Updated by Irina Neculita over 4 years ago

validated with Modelio 3.0 Open Source Build Id: 1.0.0.201307142334 – windows 7

#8 Updated by Irina Neculita over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF