Issue #12

Exception during Modelio shutdown

Added by Marijan Matic almost 8 years ago. Updated over 7 years ago.

Status:ClosedStart date:19 October 2011
Priority:MediumDue date:
Assignee:-% Done:

100%

Category:-
Target version:Modelio 2.1.1

Description

Version 2.0.0 Build ID: 2.0.00.8006 – 20111003

Sometimes during application shutdown the error message box is displayed with following exception generated in the log file.

!ENTRY org.eclipse.osgi 4 0 2011-10-19 15:23:06.269
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.IllegalStateException: The modeling session is not open. It cannot be used)
    at org.eclipse.swt.SWT.error(SWT.java:4083)
    at org.eclipse.swt.SWT.error(SWT.java:3998)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:137)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)
    at org.eclipse.swt.widgets.Display.release(Display.java:3713)
    at org.eclipse.swt.graphics.Device.dispose(Device.java:295)
    at com.modeliosoft.modelio.app.intro.Application.start(Application.java:82)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
Caused by: java.lang.IllegalStateException: The modeling session is not open. It cannot be used
    at com.modeliosoft.modelio.core.ModelingSession.assertIsOpen(ModelingSession.java:517)
    at com.modeliosoft.modelio.core.ModelingSession.getModel(ModelingSession.java:266)
    at com.modeliosoft.modelio.diagram.elements.core.model.ModelManager.resolveRef(ModelManager.java:80)
    at com.modeliosoft.modelio.diagram.elements.common.abstractdiagram.DiagramPersistence.loadDiagram(DiagramPersistence.java:53)
    at com.modeliosoft.modelio.diagram.elements.common.abstractdiagram.GmAbstractDiagram$ModelChangeListener$2.run(GmAbstractDiagram.java:579)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
    ... 17 more

History

#1 Updated by Christophe Demeulemeester over 7 years ago

  • Status changed from New to Closed
  • Target version set to Modelio 2.1.1

#2 Updated by Christophe Demeulemeester over 7 years ago

Already fixed in Modelio 2.1.

Also available in: Atom PDF