Issue #144

Quick reference selection mode isn't always aborted when input loses focus

Added by WGH WGH almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:21 October 2013
Priority:MediumDue date:
Assignee:Philippe Vlaemynck% Done:

100%

Category:-
Target version:Modelio 3.0.1

Description

The subject might be vague, as I don’t know how this feature is properly called.

Anyway, this bug manifests everywhere you can select a reference by clicking on some object. I’ll provide a simple way of reproduction:

  1. Create Interaction (aka Sequence) digram
  2. Create a Lifeline inside
  3. Click null beside “Represented by” field in “Element” tab below
  4. Modelio will now entering something I call “Quick reference selection mode”
  5. (if you press Esc at this point, selection will abort normally)
  6. Click on “Name” field name just above. Note that you must click on field name, not on field value. If you click on value, the selection will also be aborted normally.
  7. Now, although selection will appear aborted, it won’t be actually aborted. You will be still able to select objects that qualify as, in this case, Role. Esc button won’t abort this mode. You won’t be able to select other objects on this or other diagrams (selection border will appear, but contents of “Element” tab won’t change).
  8. The only way out of this is to either select something appropriate, or focus on that control again and press Esc.

Modelio build 201309241706. I confirmed bug on two different platforms:

  1. Windows 7 64-bit running 64-bit Java build 1.7.0_07-b11
  2. Gentoo Linux 64 bit running 64-bit IcedTea7 2.3.2

History

#1 Updated by admin admin almost 4 years ago

  • Assignee set to Philippe Vlaemynck

To WGH WGH: Thank you for you accurate description of this bug which helped us a lot to fix it. The feature you call “Quick reference selection mode” is internally called “picking” as the end-user just has to ‘pick’ an element to designate it.

#2 Updated by Philippe Vlaemynck almost 4 years ago

  • Status changed from New to Resolved

#3 Updated by admin admin almost 4 years ago

  • Target version set to Modelio 3.0.1

#4 Updated by Christophe Demeulemeester almost 4 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Validated with Modelio 3.0.01 – 201310301434 – 64-bit on Windows Seven SP1 64-bit.

#5 Updated by WGH WGH almost 4 years ago

I’ve updated Modelio to build 201311041840, but this still can be reproduced.

#6 Updated by Olivier Saint Léger almost 4 years ago

Validated with Modelio-by-Modeliosoft 3.0.01 – 201311041840 64-bit on Ubuntu 12.04 64-bit

#7 Updated by WGH WGH almost 4 years ago

What do you mean by “validated”? Do you confirm that the bug is gone?

As of me, the bug is still present, I confirmed that both on Linux and Windows. I even deleted ~/.modelio and created an empty project.

#8 Updated by Olivier Saint Léger almost 4 years ago

The fix was validated with Modelio-by-Modeliosoft 3.0.01 – 201311041840 64-bit on Ubuntu 12.04 64-bit.

The bug was NOT observed with the above configuration.

#9 Updated by Christophe Demeulemeester almost 4 years ago

Can you provide us with a video ?

We want to make sure that we proceed the same way as you when trying to reproduce.

You can use free tools like ‘RecordMyDesktop’ or ‘Vokoscreen’…

#10 Updated by WGH WGH almost 4 years ago

Well, you’re right that the repro I provided no longer triggers the bug.

However, try to do so with Lifeline backed by actual Role that represents some class. Instead of creating plain Lifeline, create a Class and drag'n'drop it to the Sequence diagram.

#11 Updated by WGH WGH almost 4 years ago

Sorry, I meant something completely different. It isn’t so simple to reproduce now, but I’m sure I encountered it least once since the upgrade.

I will post reproduction a bit later.

#12 Updated by WGH WGH almost 4 years ago

OK, consider the following situation: Interaction diagram again, a message sent to a Lifeline that is backed by Role with a base class. Empty Lifeline or Role without a base won’t work. Select the message arrow, open Invoked drop-down list and here we go again.

Also available in: Atom PDF