Issue #150

(BPMN) Message flow inside a pool is not detected by Audit as wrong

Added by Johannes Bumüller over 6 years ago. Updated about 1 year ago.

Status:ClosedStart date:07 November 2013
Priority:MediumDue date:
Assignee:Antonin Abhervé% Done:

100%

Category:-
Target version:Modelio 3.1.1

Description

I noticed, if I create a BPMN-Chart, with a single Pool and create a Message Flow inside it (see Diageam view image), the Audit doesn’t show any error regarding that (see Audit view image). But it is forbidden in BMPN:

Note that Message Flows cannot connect to objects that are within the same Pool.

(see for exampe http://www.omg.org/spec/BPMN/2.0/PDF/ page 43)

Instead the Audit shows me a message which I do not understand, given I have both a start and a end event (see Audit view image).

2013-11-07_10.16.25_am.png - Diagram view (122 KB) Johannes Bumüller, 07 November 2013 10:27

2013-11-07_10.16.37_am.png - Audit view (33.4 KB) Johannes Bumüller, 07 November 2013 10:27

History

#1 Updated by Etienne Brosse over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Antonin Abhervé

#2 Updated by Christophe Demeulemeester over 6 years ago

  • Target version set to 192

#3 Updated by Antonin Abhervé over 6 years ago

Normally it is not possible to create a message flow betweens 2 element in the same pool. This would be fixed by desabeling creation of this link in this context, not with an audit rule.

Antonin Abhervé

#4 Updated by Johannes Bumüller over 6 years ago

Thanks, that sounds even better. I tried this several times on a plain Diagram, as in the image attached to the issue. All the time I was able to create a flow such that. Are you not able to reproduce it?

#5 Updated by Christophe Demeulemeester almost 6 years ago

  • Status changed from Assigned to Closed
  • Target version changed from 192 to Modelio 3.1.1
  • % Done changed from 0 to 100

Validated with Modelio 3.1.1 – 201402210039 64-bit on Windows 8.1 64-bit.

Also available in: Atom PDF