Issue #165

element view bug

Added by Robin Zhang almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:06 January 2014
Priority:UrgentDue date:
Assignee:Christophe Malgouyres% Done:

100%

Category:-
Target version:Modelio 3.1.2

Description

within modelio3.1, created a class in class diagram, it will be waite a long time after clicked the element view.

log_file.txt Magnifier (26.3 KB) Matthieu Bachelier, 09 January 2014 12:00

dump.zip (28.6 KB) Matthieu Bachelier, 11 January 2014 01:39


Related issues

Related to Issue #169: element view problem Closed 07 January 2014
Related to Issue #180: Modelio freezes when Element Tab is open Closed 20 February 2014

History

#1 Updated by Matthieu Bachelier almost 4 years ago

I have the same problem too. It should be in higher priority: it’s almost unusable.

#2 Updated by Cédric Marin almost 4 years ago

Hello, I can’t reproduce the problem here. What I did :

  1. open a project
  2. create a class diagram
  3. choose the “create a class” tool
  4. click in the diagram
    ==> a class is created immediately
  5. click on the class
  6. click on the “Element” tab to display the element properties
    ==> the properties are displayed immediately.

Can you detail the steps to reproduce the issue ?
Can you tell us your machine specs (CPU, RAM …) and your operating system (Windows/Linux 32/64bits …)?

In order to help us fixing the problem you may also:

  1. Go to the “Configuration/Preferences” menu,
  2. In the “Administration” tab, choose “Debug” Log level,
  3. Reproduce the problem,
  4. Go to the “Help/Open log file” menu,
  5. Send the log content as an attached file

Thanks for the help!

#3 Updated by Matthieu Bachelier almost 4 years ago

Cédric Marin wrote:

Hello, I can’t reproduce the problem here. What I did :

  1. open a project
  2. create a class diagram
  3. choose the “create a class” tool
  4. click in the diagram
    ==> a class is created immediately
  5. click on the class
  6. click on the “Element” tab to display the element properties
    ==> the properties are displayed immediately.

Can you detail the steps to reproduce the issue ?
Can you tell us your machine specs (CPU, RAM …) and your operating system (Windows/Linux 32/64bits …)?

In order to help us fixing the problem you may also:

  1. Go to the “Configuration/Preferences” menu,
  2. In the “Administration” tab, choose “Debug” Log level,
  3. Reproduce the problem,
  4. Go to the “Help/Open log file” menu,
  5. Send the log content as an attached file

Thanks for the help!

The steps to reproduce the bug are correct. It takes almost 1 minute to display properties! And each time I interact with something, it takes another minute if the selected view is “Element view” :(

In attachement, you’ll find a debug file. But it doesn’t contain any DEBUG terms (it seems).

My workstations are : Windows 7 32-bits (Intel Pentium G630, 4GB) and Windows 8.1 64-bits (Intel Core i37xx, 8GB).

#4 Updated by Cédric Marin almost 4 years ago

The log effectively contains nothing useful.

There is another way to help us but it will require you to have the Oracle JDK 1.7 installed:

  1. First get if you don’t have it the Oracle JDK 1.7 (older may not work).
    You can find it here http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

  2. In the jdk/bin directory you will find a ‘jvisualvm’ tool,
    run it and close the “start page” tab.

  3. Run Modelio
    ==> In JVisualVM browser, the Modelio process will appear.

  4. In JVisualVM browser, double click on the Modelio process.
    ==> Modelio is now attached to JVisualVM.

  5. Select the “Threads” tab.

  6. In Modelio, reproduce the problem.

  7. While Modelio is stuck/busy/frozen/…, go to JVisualVM and click on “Thread dump” button 3 times, waiting a few seconds between each click.
    ==> 3 new tabs will open with all threads stack trace.

  8. Send us these tabs content as attached files.

  9. You may also try the “Sampler” which displays where in the code CPU spends its time.

Thanks for the help!

#5 Updated by Matthieu Bachelier almost 4 years ago

Cédric Marin wrote:

The log effectively contains nothing useful.

There is another way to help us but it will require you to have the Oracle JDK 1.7 installed:

  1. First get if you don’t have it the Oracle JDK 1.7 (older may not work).
    You can find it here http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

  2. In the jdk/bin directory you will find a ‘jvisualvm’ tool,
    run it and close the “start page” tab.

  3. Run Modelio
    ==> In JVisualVM browser, the Modelio process will appear.

  4. In JVisualVM browser, double click on the Modelio process.
    ==> Modelio is now attached to JVisualVM.

  5. Select the “Threads” tab.

  6. In Modelio, reproduce the problem.

  7. While Modelio is stuck/busy/frozen/…, go to JVisualVM and click on “Thread dump” button 3 times, waiting a few seconds between each click.
    ==> 3 new tabs will open with all threads stack trace.

  8. Send us these tabs content as attached files.

  9. You may also try the “Sampler” which displays where in the code CPU spends its time.

Thanks for the help!

You’ll find requested files in attachement!

#6 Updated by Cédric Marin almost 4 years ago

Hello,

The bug is related to a third party library (ktable) and could occur only on Windows.

It may be caused by one displayed property being very long (much more than 100 characters) .

As a workaround, check the name and all properties of your elements. By example if you use the Java module, check attributes initial values.

#7 Updated by Cédric Marin almost 4 years ago

I created an issue on the ktable forge: https://sourceforge.net/p/ktable/bugs/54/

#8 Updated by András Lukács over 3 years ago

This is irritating, indeed. Slows down modelling so much that one is considering dumping Modelio altogether.

When I select a model element or the background, and the Element tab is visible, 90% of the times it takes ca. 5 seconds for the user interface to be usable again. In the meantime, the horizontal scroll bar of the right-hand section of the Element tab (this is where you can set the active element’s properties) is rapidly being resized several times.

I don’t mean to be smarter than the guys who maintain Modelio but isn’t there some BeginUpdate() / EndUpdate() functionality in ktable they could use when modifying the contents of the window so it should not want to display itself after every single change?

#9 Updated by Christophe Demeulemeester over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Christophe Demeulemeester
  • Priority changed from Medium to Urgent

#10 Updated by Christophe Demeulemeester over 3 years ago

This issue has been reported by several users, but we have been unable to reproduce it here, although we’ve tested it on several workstations with different OS:

Windows 8.1 (x86_64)
Windows 7 SP1 (x86/x86_64)
Redhat Enterprise Linux 6 (x86/x86_64)
Ubuntu Linux 12.04 LTS (i386/amd64)
Debian 6 (i386/amd64)
Mac OS X 10.8.5
Mac OS X 10.9.2

Users who reproduce it only use a very simple model, just a single Class in a Class Diagram, with no special properties…

Reproduced by Matthieu Bachelier:

Start any project under Windows 7 or Windows 8.
It will freeze with one class in the class diagram. 
No need to have a specific project.

Reproduced by András Lukács:

I mainly use Modelio on two notebook computers.  
Both run Windows 7 Home Premium 64 bit, and are always updated by the latest Windows and Microsoft updates. 
I can only give a hardware specification of one of them right now:

Windows Home Premium 64 bit (6.1, build 7601)
Toshiba Satellite L670
CPU: i3 M380 @ 2.53GHz
memory: 4 GB
video card: ATI Mobility Radeon HD 5470
main video drivers: atiu9p64.dll, aticfx64.dll, version 8.712.2.1000; DDI version: 11; WDM 1.1
DirectX 11
screen resolution: 1600 x 900, 32 bit (although I guess this won't matter much)
sound card: Realtek High Definition Audio
sound card driver: RTKVHD64.sys; version 6.00.0001.6069

Reproduced by Francesco Maria Cultrera:

OS Name:                   Microsoft Windows 8.1
OS Version:                6.3.9600 N/A Build 9600
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Workstation
OS Build Type:             Multiprocessor Free
System Manufacturer:       Sony Corporation
System Model:              SVS15112C5E
System Type:               x64-based PC
Processor(s):              1 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 58 Stepping 9 GenuineIntel ~2200 Mhz
BIOS Version:              Insyde Corp. R1021C8, 3/13/2013
Windows Directory:         C:\WINDOWS
System Directory:          C:\WINDOWS\system32
Boot Device:               \Device\HarddiskVolume3
System Locale:             it;Italian (Italy)
Input Locale:              it;Italian (Italy)
Time Zone:                 (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
Total Physical Memory:     12,167 MB
Available Physical Memory: 9,499 MB
Virtual Memory: Max Size:  14,023 MB
Virtual Memory: Available: 11,303 MB
Virtual Memory: In Use:    2,720 MB
Page File Location(s):     C:\pagefile.sys
Hotfix(s):                 56 Hotfix(s) Installed.
                           [01]: KB2899189_Microsoft-Windows-CameraCodec-Package
                           [02]: KB2843630
                           [03]: KB2862152
                           [04]: KB2868626
                           [05]: KB2876331
                           [06]: KB2883200
                           [07]: KB2884101
                           [08]: KB2884846
                           [09]: KB2887595
                           [10]: KB2889543
                           [11]: KB2891214
                           [12]: KB2892074
                           [13]: KB2893294
                           [14]: KB2894029
                           [15]: KB2894179
                           [16]: KB2894853
                           [17]: KB2898514
                           [18]: KB2898785
                           [19]: KB2898868
                           [20]: KB2898871
                           [21]: KB2900986
                           [22]: KB2901101
                           [23]: KB2901125
                           [24]: KB2901128
                           [25]: KB2902892
                           [26]: KB2903939
                           [27]: KB2904266
                           [28]: KB2904440
                           [29]: KB2908816
                           [30]: KB2909210
                           [31]: KB2909569
                           [32]: KB2909921
                           [33]: KB2911106
                           [34]: KB2912390
                           [35]: KB2913152
                           [36]: KB2913270
                           [37]: KB2913320
                           [38]: KB2913760
                           [39]: KB2914218
                           [40]: KB2916036
                           [41]: KB2917929
                           [42]: KB2917993
                           [43]: KB2919394
                           [44]: KB2919442
                           [45]: KB2919907
                           [46]: KB2923300
                           [47]: KB2923528
                           [48]: KB2923768
                           [49]: KB2925418
                           [50]: KB2928680
                           [51]: KB2929825
                           [52]: KB2929961
                           [53]: KB2930275
                           [54]: KB2934802
                           [55]: KB2938527
                           [56]: KB976002
Network Card(s):           3 NIC(s) Installed.
                           [01]: Controller Realtek PCIe GBE Family
                                 Connection Name: Ethernet
                           [02]: Intel(R) Centrino(R) Advanced-N 6235
                                 Connection Name: Wi-Fi
                                 Status:          Media disconnected
                           [03]: VirtualBox Host-Only Ethernet Adapter
                                 Connection Name: VirtualBox Host-Only Network
                                 DHCP Enabled:    No
Hyper-V Requirements:      VM Monitor Mode Extensions: Yes
                           Virtualization Enabled In Firmware: Yes
                           Second Level Address Translation: Yes
                           Data Execution Prevention Available: Yes

#11 Updated by Chris Hoogeboom over 3 years ago

András Lukács wrote:

This is irritating, indeed. Slows down modelling so much that one is considering dumping Modelio altogether.

When I select a model element or the background, and the Element tab is visible, 90% of the times it takes ca. 5 seconds for the user interface to be usable again. In the meantime, the horizontal scroll bar of the right-hand section of the Element tab (this is where you can set the active element’s properties) is rapidly being resized several times.

I am also experiencing exactly this problem. I have a brand new project with only a few elements. Please let me know if there is any more information that would help you fix this bug!

OS Name:                   Microsoft Windows 7 Professional
OS Version:                6.1.7601 Service Pack 1 Build 7601
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Member Workstation
OS Build Type:             Multiprocessor Free
System Manufacturer:       Dell Inc.
System Model:              Precision M6600
System Type:               x64-based PC
Processor(s):              1 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 42 Stepping 7 GenuineIntel ~2401 Mhz
BIOS Version:              Dell Inc. A12, 8/9/2012
Total Physical Memory:     16,341 MB
Available Physical Memory: 10,857 MB
Virtual Memory: Max Size:  32,680 MB
Virtual Memory: Available: 25,709 MB
Virtual Memory: In Use:    6,971 MB

Edit: I experience this problem in both Modelio 3.0 and Modelio 3.1.1, but not in Modelio 2.2.2

#12 Updated by Christophe Demeulemeester over 3 years ago

Possible workaround : Switch the Element view to ‘Vertical Layout’…

#13 Updated by Christophe Malgouyres over 3 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Modelio 3.1.2
  • % Done changed from 0 to 50

This problems came from KTable refreshing its scrollbars a lot more often than necessary…

Fixed in Modelio 3.1.2.

#14 Updated by Christophe Malgouyres over 3 years ago

  • Assignee changed from Christophe Demeulemeester to Christophe Malgouyres

#15 Updated by Christophe Demeulemeester over 3 years ago

  • Target version deleted (Modelio 3.1.2)

#16 Updated by Christophe Demeulemeester over 3 years ago

  • Status changed from Resolved to Closed
  • Target version set to Modelio 3.1.2
  • % Done changed from 50 to 100

#17 Updated by Chris Hoogeboom over 3 years ago

I am still experiencing this problem in Modelio 3.1.2

Edit: Nevermind. I was using the wrong version.

#18 Updated by Christophe Demeulemeester over 3 years ago

Validated with Modelio 3.1.2 – 201405191231 64-bit on Windows 7 SP1 64-bit.

Also available in: Atom PDF