Issue #167

java.lang.ClassCastException: org.modelio.metamodel.impl.bpmn.processCollaboration.BpmnLaneImpl

Added by Michael Friedman about 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:06 January 2014
Priority:HighDue date:
Assignee:Christophe Malgouyres% Done:

100%

Category:-
Target version:Modelio 3.1.1

Description

Repeated getting an internal error dialog box with the string java.lang.ClassCastException: org.modelio.metamodel.impl.bpmn.processCollaboration.BpmnLaneImpl cannot be cast to org.modelio.metamodel.diagrams.AbstractDiagram.

Happens when working on BPMN diagram.

Error – given to kid when he sucks his bottle – is java.lang.ClassCastException: org.modelio.metamodel.impl.bpmn.processCollaboration.BpmnLaneImpl cannot be cast to org.modelio.metamodel.diagrams.AbstractDiagram org.modelio.metamodel.impl.bpmn.processCollaboration.BpmnLaneImpl cannot be cast to org.modelio.metamodel.diagrams.AbstractDiagram

History

#1 Updated by Michael Friedman about 6 years ago

This is a duplicate of 168 but apparently I do not have privileges to close it.

#2 Updated by Christophe Demeulemeester about 6 years ago

  • Assignee set to Christophe Malgouyres

#3 Updated by Christophe Demeulemeester almost 6 years ago

  • Status changed from New to Closed
  • Target version set to Modelio 3.1.1
  • % Done changed from 0 to 100

Validated with Modelio 3.1.1 – 201402210039 64-bit on Windows 8.1 64-bit.

Also available in: Atom PDF