Issue #247

Regression? PlatformUI.getWorkbench() fails on modelio 3, works on modelio 2.2

Added by Jean marie Favre over 2 years ago. Updated about 1 year ago.

Status:ClosedStart date:12 June 2015
Priority:MediumDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

Hi

the following jython code was working properly on modelio 2.2 but now fail with modelio 3.2 and modelio 3.2

from org.eclipse.ui import PlatformUI return PlatformUI.getWorkbench()

tested on on windows 7, raises “java.lang.IllegalStateException: Workbench has not been created yet.”

History

#1 Updated by Jean marie Favre over 2 years ago

The code is:

from org.eclipse.ui import PlatformUI

print PlatformUI.getWorkbench()

(print, not return…)

#2 Updated by C├ędric Marin about 1 year ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Modelio 3 is based on Eclipse RCP version 4.

PlatformUI is an Eclipse 3 class, not usable without the Eclipse 3 compatibility layer.

We don’t use this compatibility layer so you can’t use PlatformUI nor any class that relies on it.

Also available in: Atom PDF