Issue #256

Attempting to export an XMI file with Modelio 3.4 will fail if any class has a "string" attribute

Added by Gerald Humphries almost 2 years ago. Updated almost 2 years ago.

Status:ResolvedStart date:01 October 2015
Priority:UrgentDue date:
Assignee:Etienne Brosse% Done:

50%

Category:-
Target version:Modelio 3.3

Description

Version 3.4.0 Build: 201509161706 System: win32 (10.0) Architecture: x86_64 PredefinedTypes 3.4.05

To reproduce:

Create a new project Open the overview diagram Add a class Add an attribute to the class with type “string” Right click on project, export XMI, choose any location, any compatibility, then export.

Any folders that need to be created will be, but the XMI file will not be generated. The application says the generation was successful and does not give any errors. The generation works fine if no classes have strings; every other type seems to be fine.

History

#1 Updated by Gerald Humphries almost 2 years ago

Apologies for the formatting.

#2 Updated by Etienne Brosse almost 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Etienne Brosse

#3 Updated by Etienne Brosse almost 2 years ago

  • Status changed from Assigned to Resolved
  • Priority changed from High to Urgent
  • Target version set to Modelio 3.3
  • % Done changed from 0 to 50

#4 Updated by Alexandre Pocheau almost 2 years ago

As in the forum: https://www.modelio.org/forum/15-issues/3681-xmi-export-failing-on-mac-os-x10105.html#3736 I proposed a (dirty but working ?) bugfix.

Can anyone review my proposal and fix this bug?

in “xmi.src.org.modelio.xmi.generation.GenerationProperties.java”, line 117, in GenerationProperties() add:

if(ecoreUMLTypes == null){ecoreUMLTypes = new EcoreUMLTypes();}

Also available in: Atom PDF