Issue #267

In the workspace panel, renaming a project created with an older version makes it disappear

Added by Aurélien Bénel over 1 year ago. Updated 8 months ago.

Status:ResolvedStart date:17 December 2015
Priority:HighDue date:
Assignee:Cédric Marin% Done:

50%

Category:-
Target version:Modelio 3.6.0

Description

Reproduction scenario:

  • import the attached “Prenom NOM.zip” project,
  • Rename “Prenom NOM” as “Tryphon TOURNESOL”,
  • The project disappear.

Workaround:

  • import the project
  • open it
  • close (and save) it
  • rename it

Prenom NOM.zip (545 KB) Aurélien Bénel, 17 December 2015 10:45

History

#1 Updated by Cédric Marin 9 months ago

Reproduced on Modelio 3.6 .

The log file then contains a stack trace:

java.io.IOException: Parsing of 'file:///home/cmarin/modelio/workspace3.6/Tryphon%20TOURNESOL/project.conf' unexpectedly failed: java.lang.NumberFormatException: For input string: "null"
    at org.modelio.gproject.data.project.ProjectDescriptorReader.read(ProjectDescriptorReader.java:107)
    at org.modelio.gproject.data.project.ProjectDescriptorReader.read(ProjectDescriptorReader.java:141)
    at org.modelio.gproject.gproject.GProjectFactory.readProjectDirectory(GProjectFactory.java:107)
    at org.modelio.app.project.ui.views.workspace.WorkspaceTreeView$ProjectCache.rescan(WorkspaceTreeView.java:475)
    at org.modelio.app.project.ui.views.workspace.WorkspaceTreeView$ProjectCache.refresh(WorkspaceTreeView.java:453)
    at org.modelio.app.project.ui.views.workspace.WorkspaceTreeView.refreshContents(WorkspaceTreeView.java:213)
    at org.modelio.app.project.ui.views.workspace.WorkspaceTreeView.onWorkspaceContentChange(WorkspaceTreeView.java:264)
    at org.modelio.app.project.ui.views.workspace.WorkspaceTreeView$7.run(WorkspaceTreeView.java:383)
    at org.eclipse.swt.widgets.Display.timerProc(Display.java:4406)
    at org.eclipse.swt.internal.gtk.OS._g_main_context_iteration(Native Method)
    at org.eclipse.swt.internal.gtk.OS.g_main_context_iteration(OS.java:2425)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3428)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1127)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1018)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
    at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:159)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1515)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1488)
Caused by: java.lang.NumberFormatException: For input string: "null"
    at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
    at java.lang.Integer.parseInt(Integer.java:580)
    at java.lang.Integer.parseInt(Integer.java:615)
    at org.modelio.vbasic.version.Version.(Version.java:76)
    at org.modelio.gproject.data.project.ProjectDescriptorReader.decodeProject(ProjectDescriptorReader.java:240)
    at org.modelio.gproject.data.project.ProjectDescriptorReader.read(ProjectDescriptorReader.java:100)
    ... 29 common frames omitted

#2 Updated by Cédric Marin 9 months ago

  • Status changed from New to Resolved
  • Assignee set to Cédric Marin
  • % Done changed from 0 to 50

Fixed for Modelio 3.6.?

The ‘modelioVersion’ project attribute was rewritten with “null” string value.

Now an empty string is rewritten, and “null” string is treated as empty string.

#3 Updated by Cédric Marin 8 months ago

  • Target version set to Modelio 3.6.0

Also available in: Atom PDF