Issue #382

Grammatical Error in Modelio

Added by newline character 9 months ago. Updated 5 months ago.

Status:ResolvedStart date:24 February 2020
Priority:LowDue date:
Assignee:Antonio Pedro% Done:

50%

Category:-Estimated time:0.00 hour
Target version:Modelio 4.1

Description

Hello. I found a grammar mistake in Modelio 4.0.01 (have not checked if the issue occurs in other versions yet). If there is no advice that Modelio might take, it says “0 advice(s)” at the bottom of its UI (and perhaps other UI elements as well). It is considered a grammatical error since advice is an uncountable noun (according to https://dictionary.cambridge.org/grammar/british-grammar/advice-or-advise for instance) and should be replaced with “0 piece(s) of advice” or “no advice”. The line that has the source of the problem is line no. 4 in file with the following path: modelio_sources/modelio/app/audit/res/audit.properties: Audit.Status.NbAdvicesSuffix = advice(s) and it should be replaced with: Audit.Status.NbAdvicesSuffix = piece(s) of advice

I would like to correct this by myself, however I got some problems with it: 1) The docs on contributing are very poor. I don’t know how to “merge” my changes into the dev branch. I don’t either know where the dev branch is. 2) How to run the sources from IDEA and see if the changes I would make won’t degrade Modelio? Why don’t you use GitHub or something, guys? It’s much more newcomers-friendly and habitual.

History

#1 Updated by admin admin 8 months ago

  • Assignee set to Antonio Pedro
  • Target version set to Modelio 4.1

#2 Updated by admin admin 8 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

It will be fixed in next version of Modelio.

Also available in: Atom PDF