Issue #39

Line number not shown when a parsing problem occurs

Added by Normand Rivard over 7 years ago. Updated over 7 years ago.

Status:ResolvedStart date:09 March 2012
Priority:MediumDue date:
Assignee:Christophe Malgouyres% Done:

50%

Category:-
Target version:2.1.00

Description

Hi

When reversing a problematic Java source, an error message is shown at the bottom of the generation report dialog, but the exact line number where the problem occurred is not shown, so it’s very hard to investigate what is the problem.

For example, I have this message:

unexpected token: public

fichier: D:\Projets\MyProject\src\commun\util\test\MyClass.java

Not sure what is the problem with that particular file, could be a problem with Modelio Java Designer module or in the source itself, but in any case I have no idea where in that class the problem is as it doesn’t tell me which line number.

Thanks

History

#1 Updated by Christophe Malgouyres over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Christophe Malgouyres
  • Target version set to 2.1.00

Assigning the issue.

#2 Updated by Christophe Malgouyres over 7 years ago

  • Status changed from Assigned to Resolved

Parsing errors are now added to the reverse report (with file name, line and column numbers) instead of printed in the console. It is not always perfect, but it gives at least a hint on what is going wrong…

Also available in: Atom PDF